App freezing issue
Incident Report for Perkbox
Resolved
Good news. Our apps are functioning again as normal after some fixes that were pushed out quickly by our devs in the last 24 hours.

We are still working out the root cause as the issue did affect some users on both iOS and Android phones.

If the Perkbox app is frozen for you, please close the app and then re-launch it on your phone. The auto update should resolve the issue. In the case of the auto update failing and it still freezing, then please re-install the app.
Posted Sep 24, 2020 - 10:01 UTC
Monitoring
We are suspecting the iOS 14 update is causing issues to our app and for other 3rd party apps.

If you have problems loading the app on your iPhone, our current advice is to uninstall then re-install the app to get it working. Again, sorry for the inconvenience caused.
Posted Sep 22, 2020 - 17:24 UTC
Investigating
Since this morning, we've had reports that our mobile app is freezing on certain occasions (e.g. when resuming the app). Our team of engineers are currently investigating. An update will be provided shortly.

In the the mean time, please enjoy your benefits by accessing Perkbox on your browser (desktop or mobile). Sorry for any inconvenience caused.
Posted Sep 22, 2020 - 10:44 UTC
This incident affected: Apps (Perks, Recognition, Admin, Insights) and Login.