Perks Issues
Incident Report for Perkbox
Resolved
This incident has been resolved.
Posted Sep 06, 2019 - 14:42 UTC
Monitoring
The issue has been identified and a fix has been implemented. We are monitoring the Perks browsing and redemptions for any other issue.
Posted Sep 06, 2019 - 11:47 UTC
Investigating
We are currently experiencing issues with Perks affecting the ability to browse and redeem. Updates to follow.
Posted Sep 06, 2019 - 11:09 UTC
This incident affected: Apps (Perks).