Login & Perks
Incident Report for Perkbox
Resolved
This incident has been resolved.
Posted Oct 04, 2019 - 12:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 04, 2019 - 10:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 04, 2019 - 10:50 UTC
Investigating
We are currently experiencing issues with Login and Perks affecting the ability to login, browse and redeem offers. Updates to follow.
Posted Oct 04, 2019 - 10:47 UTC
This incident affected: Apps (Perks) and Login.