Medical Login Issues
Incident Report for Perkbox
Resolved
The team have identified the issue preventing Perkbox Medical App users from logging in, this has now been fixed and logins should be working on both Android & iOS.
Posted Jan 17, 2019 - 13:03 UTC
Investigating
We're currently experiencing login issues affecting iOS & Android users of the Perkbox Medical app. Our team is investigating and we will post more information as it comes available.

To access your account for appointments or medical details in the mean time, please visit https://member.doctorcareanywhere.com/Account/Login and log in with your Perkbox Medical credentials.
Posted Jan 17, 2019 - 11:55 UTC
This incident affected: Apps (Medical).