Redeeming perks is taking longer than usual and in some cases timing out
Incident Report for Perkbox
Resolved
Performance is operating normally. The implemented fix successfully resolved the performance issue.
Posted Nov 27, 2019 - 16:58 UTC
Monitoring
Performance has been back to normal for more than an hour. We'll continue to monitor
Posted Nov 27, 2019 - 12:07 UTC
Identified
We've identified the issue and are now working on a fix.
Posted Nov 27, 2019 - 10:55 UTC
Investigating
We are currently investigating this issue. An update will be posted shortly.
Posted Nov 27, 2019 - 10:44 UTC
This incident affected: Apps (Perks).