Payments are currently not being processed via Barclaycard SmartPay

Incident Report for Perkbox

Resolved

Barclaycards confirmed that the issue has been resolved.

Payments on our Perks platform are now back to normal.
Posted Oct 31, 2018 - 12:03 UTC

Monitoring

Barclaycard SmartPay is now back to normal service levels. We expect Barclayscard to confirm that the issue has been closed shortly.
Posted Oct 31, 2018 - 11:25 UTC

Identified

Barclaycard SmartPay is down and being investigated by their technical team.

Currently payments on our Perks platform will not go through. We will post updates here as soon as we have more information from Barclaycard.
Posted Oct 31, 2018 - 10:08 UTC
This incident affected: Apps (Perks).